PlotLegacy Property (ActiveX)

Toggles whether legacy plot scripts are allowed to run.

Supported platforms: Windows only

Signature

VBA:

object.PlotLegacy
object

Type: PreferencesOutput

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is False.

Examples

VBA:

Sub Example_PlotLegacy()
    ' This example reads and modifies the PlotLegacy
    ' preference value.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesOutput
    Dim originalValue As Boolean
    
    ' Get the user preferences object

    Set ACADPref = ThisDrawing.Application.Preferences.Output
    
    ' Read and display the original value
    originalValue = ACADPref.PlotLegacy
    MsgBox "The PlotLegacy preference is set to: " & originalValue

    ' Modify the PlotLegacy preference by toggling the value
    ACADPref.PlotLegacy = Not ACADPref.PlotLegacy

    MsgBox "The PlotLegacy preference has been set to: " & ACADPref.PlotLegacy

    ' Reset the preference back to its original value
    ACADPref.PlotLegacy = originalValue
    MsgBox "The PlotLegacy preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PlotLegacy()
    ;; This example reads and modifies the PlotLegacy
    ;; preference value.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-PlotLegacy (vla-get-Output preferences)))
    (alert (strcat "The PlotLegacy preference is set to: " (if (= originalValue :vlax-true) "True" "False")))

    ;; Modify the PlotLegacy preference by toggling the value
    (vla-put-PlotLegacy (vla-get-Output preferences) (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-PlotLegacy (vla-get-Output preferences)))
    (alert (strcat "The PlotLegacy preference has been set to: " (if (= newValue :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    (vla-put-PlotLegacy (vla-get-Output preferences) originalValue)
    (alert (strcat "The PlotLegacy preference was reset back to: " (if (= originalValue :vlax-true) "True" "False")))
)