StatusID Property (ActiveX)

Gets the current active status of the viewport.

Supported platforms: Windows only

Signature

VBA:

object.StatusID(VportObj)
object

Type: Application

The object this property applies to.

VportObj

Type: Viewport

The viewport to query the status of.

Property Value

Read-only: Yes

Type: Boolean

Remarks

No additional remarks.

Examples

VBA:

Sub Example_StatusID()
    ' This example displays the setting of StatusID.

    Dim currStatusID As Boolean
    
    ' Display the current setting of statusID
    currStatusID = ThisDrawing.Application.statusID(ThisDrawing.ActiveViewport)
    MsgBox "The statusID of the active viewport is: " & currStatusID, , "StatusID Example"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_StatusID()
    ;; This example displays the setting of StatusID.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Display the current setting of statusID
    (setq currStatusID (vla-get-statusID acadObj (vla-get-ActiveViewport doc)))
    (alert (strcat "The statusID of the active viewport is: " (if (= currStatusID :vlax-true) "True" "False")))
)