HWND32 Property (ActiveX)

Gets the window handle of the window frame for a 64-bit system. (Obsolete)

Supported platforms: Windows only

Signature

VBA:

object.HWND32
object

Type: Application, Document

The objects this property applies to.

Property Value

Read-only: Yes

Type: Long

The handle of the window frame.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_HWND32()
    ' This example returns the handle (Hwnd32) of a document window. The handle can be
    ' used with WindowsAPI calls, or with ActiveX components that require a handle
    ' to a window.
   
    ' If there are no open documents, then exit
    If Documents.Count = 0 Then
        MsgBox "There are no open documents!"
        Exit Sub
    End If
    
    MsgBox "The HWND32 of the active document is: " & ActiveDocument.HWND32
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_HWND32()
    ;; This example returns the handle (Hwnd32) of a document window. The handle can be
    ;; used with WindowsAPI calls, or with ActiveX components that require a handle
    ;; to a window.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    (alert (strcat "The HWND32 of the active document is: " (itoa (vla-get-HWND32 doc))))
)