IDPair Object (ActiveX)

A special object for use with the CopyObjects method that contains the object IDs of both the source and destination objects.

Supported Platforms: Windows only

Class Information

Class Name

AcadIDPair

Object Inheritance
Object
   AcadIDPair
Create Using

VBA

User-defined variable, populated through the CopyObjects method
Access Via

VBA

User-defined variable

Members

These members are part of this object:

Methods

Properties

Events

None

Application

IsCloned

IsOwnerXlated

IsPrimary

Key

Value

None

Remarks

The IDPair object is a transient object that is used as an optional parameter in the CopyObjects method. The CopyObjects method populates the IDPair object with the object IDs of the source objects, and the newly created copied objects, thus creating a map between all of the objects that are copied and created.

The IDPair object returns all objects that are copied in the operation. This includes the primary set of objects being copied, as well as any objects owning, or owned by, the primary objects. The IDPair object also contains information about the copy and translation process.

Note: This object is used for advanced cloning functions. General users should avoid using this optional functionality.