BeginClose Event (ActiveX)

Triggered immediately after AutoCAD receives a request to close a drawing.

Supported platforms: Windows only

Signature

VBA:

object.BeginClose()
object

Type: Document

An object expression that evaluates to a valid container object. In this case, the only valid containers are the application and a document.

Remarks

You should use the BeginDocClose event rather than the BeginClose event because the BeginDocClose event enables you to keep a drawing from being closed.

No events occur while a modal dialog is displayed.

Examples

VBA:

Private Sub AcadDocument_BeginClose()
    ' This example intercepts a drawing BeginClose event.
    '
    ' This event is triggered when a drawing receives a request to close.
    '
    ' To trigger this example event: Close an open drawing

    MsgBox "A drawing has just been closed!"
End Sub

Visual LISP:

Not available