Toggles the display of full-screen tracking vectors.
Supported platforms: Windows only
VBA:
object.FullScreenTrackingVector
Type: PreferencesDrafting
The object this property applies to.
Read-only: No
Type: Boolean
The initial value for this property is True.
VBA:
Sub Example_FullScreenTrackingVector() ' This example reads and modifies the preference value that controls ' the display of full-screen tracking vectors. ' When finished, this example resets the preference value back to ' its original value. Dim ACADPref As AcadPreferencesDrafting Dim originalValue As Variant, newValue As Variant ' Get the drafting preferences object Set ACADPref = ThisDrawing.Application.preferences.Drafting ' Read and display the original value originalValue = ACADPref.FullScreenTrackingVector MsgBox "The FullScreenTrackingVector preference is set to: " & originalValue ' Modify the FullScreenTrackingVector preference by toggling the value ACADPref.FullScreenTrackingVector = Not (originalValue) newValue = ACADPref.FullScreenTrackingVector MsgBox "The FullScreenTrackingVector preference has been set to: " & newValue ' Reset the preference back to its original value ' ' * Note: Comment out this last section to leave the change to ' this preference in effect ACADPref.FullScreenTrackingVector = originalValue MsgBox "The FullScreenTrackingVector preference was reset back to: " & originalValue End Sub
Visual LISP:
(vl-load-com) (defun c:Example_FullScreenTrackingVector() ;; This example reads and modifies the preference value that controls ;; the display of full-screen tracking vectors. ;; When finished, this example resets the preference value back to ;; its original value. (setq acadObj (vlax-get-acad-object)) (setq preferences (vla-get-Preferences acadObj)) ;; Get the drafting preferences object (setq ACADPref (vla-get-Drafting preferences)) ;; Read and display the original value (setq originalValue (vla-get-FullScreenTrackingVector ACADPref)) (alert (strcat "The FullScreenTrackingVector preference is set to: " (if (= originalValue :vlax-true) "True" "False"))) ;; Modify the FullScreenTrackingVector preference by toggling the value (vla-put-FullScreenTrackingVector ACADPref (if (= originalValue :vlax-true) :vlax-false :vlax-true)) (setq newValue (vla-get-FullScreenTrackingVector ACADPref)) (alert (strcat "The FullScreenTrackingVector preference has been set to: " (if (= newValue :vlax-true) "True" "False"))) ;; Reset the preference back to its original value ;; ;; * Note: Comment out this last section to leave the change to ;; this preference in effect (vla-put-FullScreenTrackingVector ACADPref originalValue) (alert (strcat "The FullScreenTrackingVector preference was reset back to: " (if (= originalValue :vlax-true) "True" "False"))) )