Specifies the color name and book name of the color.
Supported platforms: Windows only
VBA:
object.SetNames ColorName, ColorBook
Type: AcCmColor
The object this method applies to.
Access: Input-only
Type: String
The name of the color.
Access: Input-only
Type: String
The color book name of the color.
No return value.
No additional remarks.
VBA:
Sub Example_SetNames() 'This example draws a circle and 'returns the color name and color book name of the color. Dim col As AcadAcCmColor Set col = AcadApplication.GetInterfaceObject("AutoCAD.AcCmColor.20") col.SetRGB 125, 175, 235 col.SetNames "MyColor", "MyColorBook" Dim cir As AcadCircle Dim pt(0 To 2) As Double Set cir = ThisDrawing.ModelSpace.AddCircle(pt, 2) cir.TrueColor = col ZoomAll Dim retCol As AcadAcCmColor Set retCol = cir.TrueColor MsgBox "BookName=" & col.BookName & vbLf & _ "ColorName=" & col.ColorName End Sub
Visual LISP:
(vl-load-com) (defun c:Example_SetNames() ;; This example draws a circle and ;; returns the color name and color book name of the color. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) (setq col (vlax-create-object "AutoCAD.AcCmColor.20")) (vla-SetRGB col 125 175 235) (vla-SetNames col "MyColor" "MyColorBook") (setq pt (vlax-3d-point 0 0 0)) (setq modelSpace (vla-get-ModelSpace doc)) (setq cir (vla-AddCircle modelSpace pt 2)) (vla-put-TrueColor cir col) (vla-ZoomAll acadObj) (setq retCol (vla-get-TrueColor cir)) (alert (strcat "BookName=" (vla-get-BookName col) "\nColorName=" (vla-get-ColorName col) ) ) (vlax-release-object col) )