FullName Property (ActiveX)

Gets the name of the application or document, including the path.

Supported platforms: Windows only

Signature

VBA:

object.FullName
object

Type: Application, Document

The objects this property applies to.

Property Value

Read-only: Yes

Type: String

The name and path of the application or document.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_FullName()
    ' This example uses the FullName property to find
    ' the full name of the current drawing, and of
    ' the application.
    
    ' Find the full name of current drawing file including path.
    ' (If the drawing has not been saved, this name will be blank.)
    Dim docName As String
    docName = ThisDrawing.FullName
    MsgBox "The full name of the current drawing is " & docName, , "FullName Example"
    
    ' Find the full name of application
    Dim appName As String
    appName = ThisDrawing.Application.FullName
    MsgBox "The full name of the current application is " & appName, , "FullName Example"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_FullName()
    ;; This example uses the FullName property to find
    ;; the full name of the current drawing, and of
    ;; the application.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Find the full name of current drawing file including path.
    ;; (If the drawing has not been saved, this name will be blank.)
    (setq docName (vla-get-FullName doc))
    (alert (strcat "The full name of the current drawing is " docName))
    
    ;; Find the full name of application
    (setq appName (vla-get-FullName acadObj))
    (alert (strcat "The full name of the current application is " appName))
)