SetGridLineWeight2 Method (ActiveX)

Sets the grid lineweight value for the specified cell.

Supported platforms: Windows only

Signatures - Table

VBA:

object.SetGridLineWeight2 nRow, nCol, nGridLineType, lineWeight
object

Type: Table

The object this method applies to.

nRow

Access: Input-only

Type: Long

The row number of the cell to set.

nCol

Access: Input-only

Type: Long

The column number of the cell to set.

nGridLineType

Access: Input-only

Type: AcGridLineType enum

The grid linetypes to change.

  • acHorzBottom
  • acHorzInside
  • acHorzTop
  • acInvalidGridLine
  • acVertInside
  • acVertLeft
  • acVertRight
lineWeight

Access: Input-only

Type: ACAD_LWEIGHT enum

The new line weight.

  • acLnWt000
  • acLnWt005
  • acLnWt009
  • acLnWt013
  • acLnWt015
  • acLnWt018
  • acLnWt020
  • acLnWt025
  • acLnWt030
  • acLnWt035
  • acLnWt040
  • acLnWt050
  • acLnWt053
  • acLnWt060
  • acLnWt070
  • acLnWt080
  • acLnWt090
  • acLnWt100
  • acLnWt106
  • acLnWt120
  • acLnWt140
  • acLnWt158
  • acLnWt200
  • acLnWt211
  • acLnWtByLayer
  • acLnWtByBlock
  • acLnWtByLwDefault

Signatures - TableStyle

VBA:

object.SetGridLineWeight2 bstrCellStyle, gridLineType, Lineweight
object

Type: TableStyle

object this method applies to.

bstrCellStyle

Access: Input-only

Type: String

A named cell style in the table style.

gridLineType

Access: Input-only

Type: AcGridLineType enum

The grid linetypes to change.

  • acHorzBottom
  • acHorzInside
  • acHorzTop
  • acInvalidGridLine
  • acVertInside
  • acVertLeft
  • acVertRight
Lineweight

Access: Input-only

Type: ACAD_LWEIGHT enum

The new line weight.

  • acLnWt000
  • acLnWt005
  • acLnWt009
  • acLnWt013
  • acLnWt015
  • acLnWt018
  • acLnWt020
  • acLnWt025
  • acLnWt030
  • acLnWt035
  • acLnWt040
  • acLnWt050
  • acLnWt053
  • acLnWt060
  • acLnWt070
  • acLnWt080
  • acLnWt090
  • acLnWt100
  • acLnWt106
  • acLnWt120
  • acLnWt140
  • acLnWt158
  • acLnWt200
  • acLnWt211
  • acLnWtByLayer
  • acLnWtByBlock
  • acLnWtByLwDefault

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Examples

VBA:

Not available

Visual LISP:

Not available