BeginPlot Event (ActiveX)

Triggered immediately after AutoCAD receives a request to print a drawing.

Supported platforms: Windows only

Signature

VBA:

object.BeginPlot(DrawingName)
object

Type: Application, Document

An object expression that evaluates to a valid container object. In this case, the only valid containers are the application and a document.

DrawingName

Type: String; input to the handler

The name of the drawing that is being sent to the printer.

Remarks

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Private Sub AcadDocument_BeginPlot(ByVal DrawingName As String)
    ' This example intercepts a drawing BeginPlot event.
    '
    ' This event is triggered when a drawing receives a plot request.
    '
    ' To trigger this example event: Plot an open drawing

    ' Use the "DrawingName" variable to determine which drawing is about to plot
    MsgBox "A drawing has just received a request to plot for: " & DrawingName

End Sub

Visual LISP:

Not available