Green Property (ActiveX)

Specifies the green component of the True Color.

Supported platforms: Windows only

Signature

VBA:

object.Green
object

Type: AcCmColor

The object this property applies to.

Property Value

Read-only: Yes

Type: Long

The green component, from 0-255, of AcCmColor.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Green()
    ' This example draws a line and returns the RGB values
    Dim color As AcadAcCmColor
    Set color = AcadApplication.GetInterfaceObject("AutoCAD.AcCmColor.20")
    color.SetRGB 80, 100, 244
    
    Dim line As AcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double
        
    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#
        
    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    ZoomAll
    
    line.TrueColor = color
    Dim retcolor As AcadAcCmColor
    Set retcolor = line.TrueColor
    
    MsgBox "Red = " & retcolor.Red & vbLf & _
           "Green = " & retcolor.Green & vbLf & _
           "Blue = " & retcolor.Blue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Green()
    ;; This example draws a line and returns the RGB values
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq color (vlax-create-object "AutoCAD.AcCmColor.20"))
    (vla-SetRGB color 80 100 244)
    
    (setq startPoint (vlax-3d-point 1 1 0)
          endPoint (vlax-3d-point 5 5 0))
        
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq line (vla-AddLine modelSpace startPoint endPoint))
    (vla-ZoomAll acadObj)
    
    (vla-put-TrueColor line color)
    (setq retcolor (vla-get-TrueColor line))
    
    (alert (strcat "Red = " (itoa (vla-get-Red retcolor))
                   "\nGreen = " (itoa (vla-get-Green retcolor))
                   "\nBlue = " (itoa (vla-get-Blue retcolor))
           )
    )

    (vlax-release-object color)
)