PrintSpoolerPath Property (ActiveX)

Specifies the directory for the print spool files. AutoCAD writes the plot to this location.

Supported platforms: Windows only

Signature

VBA:

object.PrintSpoolerPath
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The directory for the print spool files.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_PrintSpoolerPath()
    ' This example returns the current setting of
    ' PrintSpoolerPath. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currPrintSpoolerPath As String
    Dim newPrintSpoolerPath As String
    
    Set preferences = ThisDrawing.Application.Preferences
    
    ' Retrieve the current PrintSpoolerPath value
    currPrintSpoolerPath = preferences.Files.PrintSpoolerPath
    MsgBox "The current value for PrintSpoolerPath is " & currPrintSpoolerPath, vbInformation, "PrintSpoolerPath Example"
    
    ' Change the value for PrintSpoolerPath
    newPrintSpoolerPath = "TestPrintSpoolerPath"
    preferences.Files.PrintSpoolerPath = newPrintSpoolerPath
    MsgBox "The new value for PrintSpoolerPath is " & newPrintSpoolerPath, vbInformation, "PrintSpoolerPath Example"
    
    ' Reset PrintSpoolerPath to its original value
    preferences.Files.PrintSpoolerPath = currPrintSpoolerPath
    MsgBox "The PrintSpoolerPath value is reset to " & currPrintSpoolerPath, vbInformation, "PrintSpoolerPath Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PrintSpoolerPath()
    ;; This example returns the current setting of
    ;; PrintSpoolerPath. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current PrintSpoolerPath value
    (setq currPrintSpoolerPath (vla-get-PrintSpoolerPath (vla-get-Files preferences)))
    (alert (strcat "The current value for PrintSpoolerPath is " currPrintSpoolerPath))
    
    ;; Change the value for PrintSpoolerPath
    (setq newPrintSpoolerPath "TestPrintSpoolerPath")
    (vla-put-PrintSpoolerPath (vla-get-Files preferences) newPrintSpoolerPath)
    (alert (strcat "The new value for PrintSpoolerPath is " newPrintSpoolerPath))
    
    ;; Reset PrintSpoolerPath to its original value
    (vla-put-PrintSpoolerPath (vla-get-Files preferences) currPrintSpoolerPath)
    (alert (strcat "The PrintSpoolerPath value is reset to " currPrintSpoolerPath))
)