AuditInfo Method (ActiveX)

Evaluates the integrity of the drawing.

Supported platforms: Windows only

Signature

VBA:

object.AuditInfo FixError
object

Type: Document

The object this method applies to.

FixError

Access: Input-only

Type: Boolean

  • True: AutoCAD should attempt to fix any problems it encounters.
  • False: AutoCAD should not attempt to fix any problems it encounters.

Return Value (RetVal)

No return value.

Remarks

For every error detected, AutoCAD provides a description of the error and recommends corrective action.

If you specify FixError = True, AutoCAD will attempt to fix any errors it encounters.

Examples

VBA:

Sub Example_AuditInfo()
    ' This example has AutoCAD audit
    ' and fix any problems found
    
    ThisDrawing.AuditInfo True
    
    MsgBox "Auditing has been requested." & vbCrLf & _
           "The fix error flag is set to True", , "AuditInfo Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AuditInfo()
    ;; This example has AutoCAD audit
    ;; and fix any problems found
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    (vla-AuditInfo doc :vlax-true)
    
    (alert (strcat "Auditing has been requested."
                   "\nThe fix error flag is set to True."))
)