AlignmentPointAcquisition Property (ActiveX)

Specifies how AutoAlignment points are acquired.

Supported platforms: Windows only

Signature

VBA:

object.AlignmentPointAcquisition
object

Type: PreferencesDrafting

The object this property applies to.

Property Value

Read-only: No

Type: acAlignmentPointAcquisition enum

Remarks

The initial value for this property is acAlignPntAcquisitionAutomatic.

Examples

VBA:

Sub Example_AlignmentPointAcquisition()
    ' This example reads and modifies the preference value that controls
    ' how AutoAlignment points are acquired. When finished, this example resets
    ' the preference value back to its original value.
    
    Dim ACADPref As AcadPreferencesDrafting
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the drafting preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Drafting
    
    ' Read and display the original value
    originalValue = ACADPref.AlignmentPointAcquisition
    MsgBox "The AlignmentPointAcquisition preference is: " & originalValue

    ' Toggle and display the AlignmentPointAcquisition preference
    If ACADPref.AlignmentPointAcquisition = acAlignPntAcquisitionAutomatic Then
        ACADPref.AlignmentPointAcquisition = acAlignPntAcquisitionShiftToAcquire
    Else
        ACADPref.AlignmentPointAcquisition = acAlignPntAcquisitionAutomatic
    End If
    
    newValue = ACADPref.AlignmentPointAcquisition
    MsgBox "The AlignmentPointAcquisition preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.AlignmentPointAcquisition = originalValue
    MsgBox "The AlignmentPointAcquisition preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AlignmentPointAcquisition()
    ;; This example reads and modifies the preference value that controls
    ;; how AutoAlignment points are acquired. When finished, this example resets
    ;; the preference value back to its original value.
    (setq acadObj (vlax-get-acad-object))

    ;; Get the drafting preferences object
    (setq ACADPref (vla-get-Drafting (vla-get-Preferences acadObj)))
  
    ;; Read and display the original value
    (setq originalValue (vla-get-AlignmentPointAcquisition ACADPref))
    (alert (strcat "The AlignmentPointAcquisition preference is: " (itoa originalValue)))

    ;; Toggle and display the AlignmentPointAcquisition preference
    (if (= (vla-get-AlignmentPointAcquisition ACADPref) acAlignPntAcquisitionAutomatic)
        (vla-put-AlignmentPointAcquisition ACADPref acAlignPntAcquisitionShiftToAcquire)
        (vla-put-AlignmentPointAcquisition ACADPref acAlignPntAcquisitionAutomatic)
    )
    
    (setq newValue (vla-get-AlignmentPointAcquisition ACADPref))
    (alert (strcat "The AlignmentPointAcquisition preference has been set to: " (itoa newValue)))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-AlignmentPointAcquisition ACADPref originalValue)
    (alert (strcat "The AlignmentPointAcquisition preference was reset back to: " (itoa originalValue)))
)