SelectionChanged Event (ActiveX)

Triggered when the current pickfirst selection set changes.

Supported platforms: Windows only

Signature

VBA:

object.SelectionChanged()
object

Type: Document

An object expression that evaluates to a valid container object. In this case, the only valid container is a document.

Remarks

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Private Sub AcadDocument_SelectionChanged()
    ' This example intercepts a drawing SelectionChanged event.
    '
    ' This event is triggered when the current selection set in a drawing is modified.
    '
    ' To trigger this example event: Select or deselect objects in any open drawing

    MsgBox "The selection set in a drawing was just changed!"
End Sub

Visual LISP:

Not available