RegisteredApplications Property (ActiveX)

Gets the RegisteredApplications collection for the document.

Supported platforms: Windows only

Signature

VBA:

object.RegisteredApplications
object

Type: Database, Document

The object this property applies to.

Property Value

Read-only: Yes

Type: RegisteredApplications

The RegisteredApplications collection for the document.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_RegisteredApplications()
    ' This example finds the current RegisteredApplications collection and
    ' adds a new RegisteredApplication to that collection.
    
    Dim RegAppColl As AcadRegisteredApplications
    Set RegAppColl = ThisDrawing.RegisteredApplications
    
    ' Create a RegisteredApp named "TEST" in the current drawing
    Dim RegAppObj As AcadRegisteredApplication
    Set RegAppObj = RegAppColl.Add("TEST")
    MsgBox "A new registered application called " & RegAppObj.name & " has been added to the Registered Applications collection.", vbInformation, "RegisteredApplications Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_RegisteredApplications()
    ;; This example finds the current RegisteredApplications collection and
    ;; adds a new RegisteredApplication to that collection.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq RegAppColl (vla-get-RegisteredApplications doc))
    
    ;; Create a RegisteredApp named "TEST" in the current drawing
    (setq RegAppObj (vla-Add RegAppColl "TEST"))
    (alert (strcat "A new registered application called " (vla-get-Name RegAppObj) " has been added to the Registered Applications collection."))
)