SCMEditMode Property (ActiveX)

Determines right-click functionality in the drawing area while in Edit mode, which means that one or more objects are selected and no commands are in progress.

Supported platforms: Windows only

Signature

VBA:

object.SCMEditMode
object

Type: PreferencesUser

The object this property applies to.

Property Value

Read-only: No

Type: AcDrawingAreaSCMEdit enum

Remarks

The initial value for this property is acEdSCM.

This property can only be set when the ShortcutMenuDisplay property is set to True.

Note: The value of this property is stored in the SHORTCUTMENU system variable.

Examples

VBA:

Sub Example_SCMEditMode()
    ' This example reads and modifies the SCMEditMode
    ' preference value.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesUser
    Dim originalValue As Integer, newValue As Integer
    
    ' Get the user preferences object

    Set ACADPref = ThisDrawing.Application.Preferences.User
    
    ' Read and display the original value
    originalValue = ACADPref.SCMEditMode
    MsgBox "The SCMEditMode preference is set to: " & originalValue

    ' Modify the SCMEditMode preference by toggling the value
    ACADPref.SCMEditMode = acEdRepeatLastCommand

    MsgBox "The SCMEditMode preference has been set to: " & ACADPref.SCMEditMode

    ' Reset the preference back to its original value
    ACADPref.SCMEditMode = originalValue
    MsgBox "The SCMEditMode preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_SCMEditMode()
    ;; This example reads and modifies the SCMEditMode
    ;; preference value.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-SCMEditMode (vla-get-User preferences)))
    (alert (strcat "The SCMEditMode preference is set to: " (itoa originalValue)))

    ;; Modify the SCMEditMode preference by toggling the value
    (vla-put-SCMEditMode (vla-get-User preferences) acEdRepeatLastCommand)
    (alert (strcat "The SCMEditMode preference has been set to: " (itoa (vla-get-SCMEditMode (vla-get-User preferences)))))

    ;; Reset the preference back to its original value
    (vla-put-SCMEditMode (vla-get-User preferences) originalValue)
    (alert (strcat "The SCMEditMode preference was reset back to: " (itoa originalValue)))
)