System Property (ActiveX)

Gets the PreferencesSystem object.

Supported platforms: Windows only

Signature

VBA:

object.System
object

Type: Preferences

The object this property applies to.

Property Value

Read-only: Yes

Type: PreferencesSystem

Gets the PreferencesSystem object.

Remarks

The PreferencesSystem object holds all the options from the System tab on the Options dialog stored in the registry. All options that are stored with the drawing can be found on the DatabasePreferences object.

Examples

VBA:

Sub Example_System()
    ' This example obtains a reference to the System Preferences object
    ' from the Application Preferences object, and reads one of the System
    ' preferences
    
    Dim ACADPref As AcadPreferencesSystem
    
    ' Obtain a reference to the System Preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.System
    
    MsgBox "You now have access to the properties and methods of the System Preferences object!"
    MsgBox "The System preference BeepOnError is set to: " & ACADPref.BeepOnError

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_System()
    ;; This example obtains a reference to the System Preferences object
    ;; from the Application Preferences object, and reads one of the System
    ;; preferences
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    (alert "You now have access to the properties and methods of the System Preferences object!")
    (alert (strcat "The System preference BeepOnError is set to: " (if (= (vla-get-BeepOnError (vla-get-System preferences)) :vlax-true) "True" "False")))
)