SetColorBookColor Method (ActiveX)

Specifies the color name from an existing color book.

Supported platforms: Windows only

Signature

VBA:

object.SetColorBookColor BookName, ColorName
object

Type: AcCmColor

The object this method applies to.

BookName

Access: Input-only

Type: String

The file name of the color book.

ColorName

Access: Input-only

Type: String

The name of the color.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_SetColorBookColor()
    ' This example draws a line and specifies a color name
    ' from an existing color book.
  
    Dim FirstColor As AcadAcCmColor
    Set FirstColor = AcadApplication.GetInterfaceObject("AutoCAD.AcCmColor.20")
    FirstColor.SetRGB 80, 100, 244
  
    Dim line As AcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#

    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    ZoomAll

    FirstColor.SetColorBookColor "PANTONE+ Solid Uncoated", "PANTONE Yellow 012 U"
    line.TrueColor = FirstColor
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_SetColorBookColor()
    ;; This example draws a line and specifies a color name
    ;; from an existing color book.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    (setq FirstColor (vlax-create-object "AutoCAD.AcCmColor.20"))
    (vla-SetRGB FirstColor 80 100 244)
  
    (setq startPoint (vlax-3d-point 1 1 0)
          endPoint (vlax-3d-point 5 5 0))

    (setq modelSpace (vla-get-ModelSpace doc))
    (setq lineObj (vla-AddLine modelSpace startPoint endPoint))
    (vla-ZoomAll acadObj)

    (vla-SetColorBookColor FirstColor "PANTONE+ Solid Uncoated" "PANTONE Yellow 012 U")
    (vla-put-TrueColor lineObj FirstColor)

    (vlax-release-object FirstColor)
)