LayoutCrosshairColor Property (ActiveX)

Specifies the color of the crosshairs and text for paper space layouts.

Supported platforms: Windows only

Signature

VBA:

object.LayoutCrosshairColor
object

Type: PreferencesDisplay

The object this property applies to.

Property Value

Read-only: No

Type: OLE_COLOR (constant)

Remarks

The initial value for this property is the Windows standard text color.

To specify the crosshairs color for the model space layout, use the ModelCrosshairColor property.

Examples

VBA:

Sub Example_LayoutCrosshairColor()
    ' This example reads and modifies the preference value that controls
    ' the color of the crosshairs and text for paper space layouts.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesDisplay
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the display preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.Display
    
    ' Switch to paper space to view this change
    ThisDrawing.ActiveSpace = acPaperSpace
   
    ' Read and display the original value
    originalValue = ACADPref.LayoutCrosshairColor
    MsgBox "The LayoutCrosshairColor preference is: " & originalValue

    ' Modify the LayoutCrosshairColor preference by making it red
    ACADPref.LayoutCrosshairColor = vbRed
    newValue = ACADPref.LayoutCrosshairColor
    ThisDrawing.Regen acAllViewports
    
    MsgBox "The LayoutCrosshairColor preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.LayoutCrosshairColor = originalValue
    ThisDrawing.Regen acAllViewports
    
    MsgBox "The LayoutCrosshairColor preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_LayoutCrosshairColor()
    ;; This example reads and modifies the preference value that controls
    ;; the color of the crosshairs and text for paper space layouts.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Switch to paper space to view this change
    (vla-put-ActiveSpace doc acPaperSpace)
   
    ;; Read and display the original value
    (setq originalValue (vlax-variant-change-type (vla-get-LayoutCrosshairColor (vla-get-Display preferences)) vlax-vbLong))
    (alert (strcat "The LayoutCrosshairColor preference is: " (itoa (vlax-variant-value originalValue))))
  
    ;; Modify the LayoutCrosshairColor preference by making it red
    (vla-put-LayoutCrosshairColor (vla-get-Display preferences) (vlax-make-variant acRed 19))
    (setq newValue (vlax-variant-change-type (vla-get-LayoutCrosshairColor (vla-get-Display preferences)) vlax-vbLong))
    (vla-Regen doc acAllViewports)
    
    (alert (strcat "The LayoutCrosshairColor preference has been set to: " (itoa (vlax-variant-value newValue))))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-LayoutCrosshairColor (vla-get-Display preferences) (vlax-variant-change-type originalValue 19)) 
    (vla-Regen doc acAllViewports)
    
    (alert (strcat "The LayoutCrosshairColor preference was reset back to: " (itoa (vlax-variant-value originalValue))))
)