SCMDefaultMode Property (ActiveX)

Determines right-click functionality in the drawing area while in Default mode, which means that no objects are selected and no commands are in progress.

Supported platforms: Windows only

Signature

VBA:

object.SCMDefaultMode
object

Type: PreferencesUser

The object this property applies to.

Property Value

Read-only: No

Type: AcDrawingAreaSCMDefault enum

Remarks

The initial value for this property is acSCM.

This property can only be set when the ShortcutMenuDisplay property is set to True.

Note: The value of this property is stored in the SHORTCUTMENU system variable.

Examples

VBA:

Sub Example_SCMDefaultMode()
    ' This example reads and modifies the SCMDefaultMode
    ' preference value.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesUser
    Dim originalValue As Integer, newValue As Integer
    
    ' Get the user preferences object

    Set ACADPref = ThisDrawing.Application.Preferences.User
    
    ' Read and display the original value
    originalValue = ACADPref.SCMDefaultMode
    MsgBox "The SCMDefaultMode preference is set to: " & originalValue

    ' Modify the SCMDefaultMode preference by toggling the value
    ACADPref.SCMDefaultMode = acRepeatLastCommand

    MsgBox "The SCMDefaultMode preference has been set to: " & ACADPref.SCMDefaultMode

    ' Reset the preference back to its original value
    ACADPref.SCMDefaultMode = originalValue
    MsgBox "The SCMDefaultMode preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_SCMDefaultMode()
    ;; This example reads and modifies the SCMDefaultMode
    ;; preference value.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-SCMDefaultMode (vla-get-User preferences)))
    (alert (strcat "The SCMDefaultMode preference is set to: " (itoa originalValue)))

    ;; Modify the SCMDefaultMode preference by toggling the value
    (vla-put-SCMDefaultMode (vla-get-User preferences) acRepeatLastCommand)
    (alert (strcat "The SCMDefaultMode preference has been set to: " (itoa (vla-get-SCMDefaultMode (vla-get-User preferences)))))

    ;; Reset the preference back to its original value
    (vla-put-SCMDefaultMode (vla-get-User preferences) originalValue)
    (alert (strcat "The SCMDefaultMode preference was reset back to: " (itoa originalValue)))
)