TextWinTextColor Property (ActiveX)

Specifies the text color for the text window.

Supported platforms: Windows only

Signature

VBA:

object.TextWinTextColor
object

Type: PreferencesDisplay

The object this property applies to.

Property Value

Read-only: Yes / No

Type: OLE_COLOR (constant)

Remarks

The default color for this property is the Windows standard window text color.

Examples

VBA:

Sub Example_TextWinTextColor()
    ' This example returns the current setting of
    ' TextWinTextColor. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currTextWinTextColor As Long
    
    Set preferences = ThisDrawing.Application.Preferences
    
    ' Retrieve the current TextWinTextColor value
    currTextWinTextColor = preferences.Display.TextWinTextColor
    MsgBox "The current value for TextWinTextColor is " _
           & preferences.Display.TextWinTextColor, vbInformation, "TextWinTextColor Example"
    
    ' Change the value for TextWinTextColor
    preferences.Display.TextWinTextColor = vbGreen
    MsgBox "The new value for TextWinTextColor is " _
           & preferences.Display.TextWinTextColor, vbInformation, "TextWinTextColor Example"
    
    ' Reset TextWinTextColor to its original value
    preferences.Display.TextWinTextColor = currTextWinTextColor
    MsgBox "The TextWinTextColor value is reset to " _
           & preferences.Display.TextWinTextColor, vbInformation, "TextWinTextColor Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TextWinTextColor()
    ;; This example returns the current setting of
    ;; TextWinTextColor. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))

    ;; Get the Display preferences object
    (setq ACADPref (vla-get-Display preferences))
    
    ;; Retrieve the current TextWinTextColor value
    (setq currTextWinTextColor (vlax-variant-change-type (vla-get-TextWinTextColor ACADPref) vlax-vbLong))
    (alert (strcat "The current value for TextWinTextColor is " (itoa (vlax-variant-value currTextWinTextColor))))
    
    ;; Change the value for TextWinTextColor
    (vla-put-TextWinTextColor ACADPref (vlax-make-variant acGreen 19))
    (setq newValue (vlax-variant-change-type (vla-get-TextWinTextColor ACADPref) vlax-vbLong))
    (alert (strcat "The new value for TextWinTextColor is " (itoa (vlax-variant-value newValue))))
    
    ;; Reset TextWinTextColor to its original value
    (vla-put-TextWinTextColor ACADPref (vlax-variant-change-type currTextWinTextColor 19)) 
    (alert (strcat "The TextWinTextColor value is reset to " (itoa (vlax-variant-value currTextWinTextColor))))
)