Layouts Property (ActiveX)

Gets the Layouts collection for the document.

Supported platforms: Windows only

Signature

VBA:

object.Layouts
object

Type: Database, Document

The object this property applies to.

Property Value

Read-only: Yes

Type: Layouts

The Layouts collection for the document.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Layouts()
    ' This example will access the Layouts collection for the current drawing
    ' and list basic information about the Layouts in the drawing.

    Dim Layouts As AcadLayouts, Layout As ACADLayout
    Dim msg As String
    
    ' Get layouts collection from document object
    Set Layouts = ThisDrawing.Layouts
    
    msg = vbCrLf    ' Start with a space
    
    ' Get the names of every layout in this drawing
    For Each Layout In Layouts
        msg = msg & Layout.name & vbCrLf
    Next
    
    ' Display a list of available layouts
    MsgBox "There are " & Layouts.count & " layouts in " & _
           ThisDrawing.WindowTitle & ":" & msg
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Layouts()
    ;; This example will access the Layouts collection for the current drawing
    ;; and list basic information about the Layouts in the drawing.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Get layouts collection from document object
    (setq Layouts (vla-get-Layouts doc))
    
    (setq msg "")   ;; Start with a space
    
    ;; Get the names of every layout in this drawing
    (vlax-for Layout Layouts
        (setq msg (strcat msg (vla-get-Name Layout) "\n"))
    )
    
    ;; Display a list of available layouts
    (alert (strcat "There are " (itoa (vla-get-Count Layouts)) " layouts in "
                   (vla-get-WindowTitle doc) ":\n" msg))
)