Diameter Property (ActiveX)

Specifies the diameter of a circle.

Supported platforms: Windows only

Signature

VBA:

object.Diameter
object

Type: Circle

The object this property applies to.

Property Value

Read-only: No

Type: Double

The diameter of the circle.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Diameter()
    ' This example creates a Circle object in model space and
    ' returns the diameter of the new Circle
    
    Dim circleObj As AcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    
    ' Define the new Circle object
    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    radius = 5#
    
    ' Create the Circle object in model space
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)

    ThisDrawing.Application.ZoomAll
    
    MsgBox "The diameter of the new Circle is: " & circleObj.Diameter
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Diameter()
    ;; This example creates a Circle object in model space and
    ;; returns the diameter of the new Circle
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the new Circle object
    (setq centerPoint (vlax-3d-point 0 0 0)  
          radius 5)
    
    ;; Create the Circle object in model space
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq circleObj (vla-AddCircle modelSpace centerPoint radius))

    (vla-ZoomAll acadObj)
    
    (alert (strcat "The diameter of the new Circle is: " (rtos (vla-get-Diameter circleObj) 2)))
)