AutoSnapAperture Property (ActiveX)

Toggles the display of the AutoSnap aperture.

Supported platforms: Windows only

Signature

VBA:

object.AutoSnapAperture
object

Type: PreferencesDrafting

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is True.

The AutoSnap aperture is displayed in the center of the crosshairs when you snap to an object. This option is available only when the AutoSnap marker, magnet, or tooltip is enabled.

Note: The value of this property is stored in the APBOX system variable.

Examples

VBA:

Sub Example_AutoSnapAperture()
    ' This example reads and modifies the preference value that controls
    ' the display of the AutoSnap aperture.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesDrafting
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the drafting preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Drafting
    
    ' Read and display the original value
    originalValue = ACADPref.AutoSnapAperture
    MsgBox "The AutoSnapAperture preference is set to: " & originalValue

    ' Modify the AutoSnapAperture preference by toggling the value
    ACADPref.AutoSnapAperture = Not (originalValue)
    newValue = ACADPref.AutoSnapAperture
    MsgBox "The AutoSnapAperture preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.AutoSnapAperture = originalValue
    MsgBox "The AutoSnapAperture preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AutoSnapAperture()
    ;; This example reads and modifies the preference value that controls
    ;; the display of the AutoSnap aperture.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
  
    ;; Get the drafting preferences object
    (setq ACADPref (vla-get-Drafting preferences))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-AutoSnapAperture ACADPref))
    (alert (strcat "The AutoSnapAperture preference is set to: " (if (= originalValue :vlax-true) "True" "False")))

    ;; Modify the AutoSnapAperture preference by toggling the value
    (vla-put-AutoSnapAperture ACADPref (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-AutoSnapAperture ACADPref))
    (alert (strcat "The AutoSnapAperture preference has been set to: " (if (= newValue :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-AutoSnapAperture ACADPref originalValue)
    (alert (strcat "The AutoSnapAperture preference was reset back to: " (if (= originalValue :vlax-true) "True" "false")))
)