Output Property (ActiveX)

Gets the PreferencesOutput object.

Supported platforms: Windows only

Signature

VBA:

object.Output
object

Type: Preferences

The object this property applies to.

Property Value

Read-only: Yes

Type: PreferencesOutput

Gets the PreferencesOutput object.

Remarks

The PreferencesOutput object holds all the options from the Output tab on the Options dialog stored in the registry. All options that are stored with the drawing can be found on the DatabasePreferences object.

Examples

VBA:

Sub Example_Output()
    ' This example obtains a reference to the Output Preferences object
    ' from the Application Preferences object, and reads one of the Output
    ' preferences
    
    Dim ACADPref As AcadPreferencesOutput
    
    ' Obtain a reference to the Output Preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Output
    
    MsgBox "You now have access to the properties and methods of the Output Preferences object!"
    MsgBox "The Output preference DefaultOutputDevice is set to: " & ACADPref.DefaultOutputDevice

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Output()
    ;; This example obtains a reference to the Output Preferences object
    ;; from the Application Preferences object, and reads one of the Output
    ;; preferences
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Obtain a reference to the Output Preferences object
    (alert (strcat "You now have access to the properties and methods of the Output Preferences object!"
                   "\nThe Output preference DefaultOutputDevice is set to: " (vla-get-DefaultOutputDevice (vla-get-Output preferences))))
)