AutoSnapMagnet Property (ActiveX)

Toggles the AutoSnap magnet.

Supported platforms: Windows only

Signature

VBA:

object.AutoSnapMagnet
object

Type: PreferencesDrafting

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is True.

Note: The value of this property is stored in the AUTOSNAP system variable.

Examples

VBA:

Sub Example_AutoSnapMagnet()
    ' This example reads and modifies the preference value that controls
    ' the AutoSnap magnet.  When finished, this example resets the
    ' preference value back to its original value.
    
    Dim ACADPref As AcadPreferencesDrafting
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the drafting preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Drafting
    
    ' Read and display the original value
    originalValue = ACADPref.AutoSnapMagnet
    MsgBox "The AutoSnapMagnet preference is set to: " & originalValue

    ' Modify the AutoSnapMagnet preference by toggling the value
    ACADPref.AutoSnapMagnet = Not (originalValue)
    newValue = ACADPref.AutoSnapMagnet
    MsgBox "The AutoSnapMagnet preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.AutoSnapMagnet = originalValue
    MsgBox "The AutoSnapMagnet preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AutoSnapMagnet()
    ;; This example reads and modifies the preference value that controls
    ;; the AutoSnap magnet.  When finished, this example resets the
    ;; preference value back to its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
  
    ;; Get the drafting preferences object
    (setq ACADPref (vla-get-Drafting preferences))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-AutoSnapMagnet ACADPref))
    (alert (strcat "The AutoSnapMagnet preference is set to: " (if (= originalValue :vlax-true) "True" "False")))

    ;; Modify the AutoSnapMagnet preference by toggling the value
    (vla-put-AutoSnapMagnet ACADPref (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-AutoSnapMagnet ACADPref))
    (alert (strcat "The AutoSnapMagnet preference has been set to: " (if (= newValue :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-AutoSnapMagnet ACADPref originalValue)
    (alert (strcat "The AutoSnapMagnet preference was reset back to: "  (if (= originalValue :vlax-true) "True" "false")))
)