Dictionaries Property (ActiveX)

Gets the Dictionaries collection for the document.

Supported platforms: Windows only

Signature

VBA:

object.Dictionaries
object

Type: Database, Document

The objects this property applies to.

Property Value

Read-only: Yes

Type: Dictionaries

The Dictionaries collection for the document.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Dictionaries()
    ' This example finds the current dictionary collection and
    ' adds a new dictionary to that collection.
    
    Dim dict As AcadDictionary
    Set dict = ThisDrawing.Dictionaries.Add("TEST")
    MsgBox "A new dictionary called " & dict.name & " has been added to the dictionaries collection.", vbInformation, "Dictionaries Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Dictionaries()
    ;; This example finds the current dictionary collection and
    ;; adds a new dictionary to that collection.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    (setq dict (vla-Add (vla-get-Dictionaries doc) "TEST"))
    (alert (strcat "A new dictionary called " (vla-get-Name dict) " has been added to the dictionaries collection."))
)