AutoSnapApertureSize Property (ActiveX)

Specifies the size of the AutoSnap aperture.

Supported platforms: Windows only

Signature

VBA:

object.AutoSnapApertureSize
object

Type: PreferencesDrafting

The object this property applies to.

Property Value

Read-only: No

Type: Long

The size of the AutoSnap aperture in pixels.

Remarks

The initial value for this property is 10.

The AutoSnap aperture is displayed in the center of the crosshairs when you snap to an object. This option is available only when the AutoSnap marker, magnet, or tooltip is enabled.

Note: The value of this property is stored in the APERTURE system variable.

Examples

VBA:

Sub Example_AutoSnapApertureSize()
    ' This example reads and modifies the preference value that controls
    ' the size of the AutoSnap aperture. When finished, this example resets
    ' the preference value back to its original value.
    
    Dim ACADPref As AcadPreferencesDrafting
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the drafting preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Drafting
    
    ' Read and display the original value
    originalValue = ACADPref.AutoSnapApertureSize
    MsgBox "The AutoSnapApertureSize preference is: " & originalValue

    ' Modify the AutoSnapApertureSize preference by setting it to 25
    ACADPref.AutoSnapApertureSize = 25
    newValue = ACADPref.AutoSnapApertureSize
    MsgBox "The AutoSnapApertureSize preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.AutoSnapApertureSize = originalValue
    MsgBox "The AutoSnapApertureSize preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AutoSnapApertureSize()
    ;; This example reads and modifies the preference value that controls
    ;; the size of the AutoSnap aperture. When finished, this example resets
    ;; the preference value back to its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
  
    ;; Get the drafting preferences object
    (setq ACADPref (vla-get-Drafting preferences))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-AutoSnapApertureSize ACADPref))
    (alert (strcat "The AutoSnapApertureSize preference is set to: " (itoa originalValue)))

    ;; Modify the AutoSnapApertureSize preference by setting it to 25
    (vla-put-AutoSnapApertureSize ACADPref 25)
    (setq newValue (vla-get-AutoSnapApertureSize ACADPref))
    (alert (strcat "The AutoSnapApertureSize preference has been set to: " (itoa newValue)))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-AutoSnapApertureSize ACADPref originalValue)
    (alert (strcat "The AutoSnapApertureSize preference was reset back to: " (itoa originalValue)))
)