EndAngle Property (ActiveX)

Specifies the end angle of an arc or ellipse.

Supported platforms: Windows only

Signature

VBA:

object.EndAngle
object

Type: Arc, Ellipse

The objects this property applies to.

Property Value

Read-only: No

Type: Double

The end angle in radians. Use 6.28 radians to specify a closed circle or ellipse.



Remarks

No additional remarks.

Examples

VBA:

Sub Example_EndAngle()
    ' This example creates an ellipse and enters the start and
    ' end angles to create an elliptical arc.
    Dim ellObj As AcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double
    
    ' Create an ellipse in model space
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)
    
    'Enter a start angle of 45 degrees, and an end angle of 270 degrees
    ellObj.startAngle = 45 * (3.14 / 180)
    ellObj.endAngle = 270 * (3.14 / 180)
    ZoomAll
    MsgBox "This ellipse has a start angle of " & ellObj.startAngle * (180 / 3.14) & " and the end angle of " & ellObj.endAngle * (180 / 3.14) & " degrees.", vbInformation, "EndAngle Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_EndAngle()
    ;; This example creates an ellipse and enters the start and
    ;; end angles to create an elliptical arc.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Create an ellipse in model space
    (setq center (vlax-3d-point 5 5 0)
          majAxis (vlax-3d-point 10 20 0)
          radRatio 0.3)
  
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq ellObj (vla-AddEllipse modelSpace center majAxis radRatio))
    
    ;; Enter a start angle of 45 degrees, and an end angle of 270 degrees
    (vla-put-StartAngle ellObj (* 45 (/ 3.14 180)))
    (vla-put-EndAngle ellObj (* 270 (/ 3.14 180)))
    (vla-ZoomAll acadObj)
    (alert (strcat "This ellipse has a start angle of " (rtos (* (vla-get-StartAngle ellObj) (/ 180 3.14)) 2) " and the end angle of " (rtos (* (vla-get-EndAngle ellObj) (/ 180 3.14)) 2) " degrees."))
)