PrinterStyleSheetPath Property (ActiveX)

Specifies the location for printer style sheet files.

Supported platforms: Windows only

Signature

VBA:

object.PrinterStyleSheetPath
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The drive and path for printer style sheet files.

Remarks

Use a semicolon (;) to separate multiple directories; however, do not end the string with a semicolon.

Examples

VBA:

Sub Example_PrinterStyleSheetPath()
    ' This example reads and modifies the preference value that controls
    ' the location for printer style sheet files.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesFiles
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the files preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.Files
    
    ' Read and display the original value
    originalValue = ACADPref.PrinterStyleSheetPath
    MsgBox "The PrinterStyleSheetPath preference is set to: " & originalValue

    ' Modify the PrinterStyleSheetPath preference by changing the path to "C:\"
    ACADPref.PrinterStyleSheetPath = "C:\"
    newValue = ACADPref.PrinterStyleSheetPath
    MsgBox "The PrinterStyleSheetPath preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.PrinterStyleSheetPath = originalValue
    MsgBox "The PrinterStyleSheetPath preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PrinterStyleSheetPath()
    ;; This example reads and modifies the preference value that controls
    ;; the location for printer style sheet files.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-PrinterStyleSheetPath (vla-get-Files preferences)))
    (alert (strcat "The PrinterStyleSheetPath preference is set to: " originalValue))

    ;; Modify the PrinterStyleSheetPath preference by changing the path to "C:\\"
    (vla-put-PrinterStyleSheetPath (vla-get-Files preferences) "C:\\")
    (setq newValue (vla-get-PrinterStyleSheetPath (vla-get-Files preferences)))
    (alert (strcat "The PrinterStyleSheetPath preference has been set to: " newValue))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-PrinterStyleSheetPath (vla-get-Files preferences) originalValue)
    (alert (strcat "The PrinterStyleSheetPath preference was reset back to: " originalValue))
)