ObjectSortByRedraws Property (ActiveX)

Toggles sorting of drawing objects by redraw order.

Supported platforms: Windows only

Signature

VBA:

object.ObjectSortByRedraws
object

Type: DatabasePreferences

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value of this property is False.

AutoCAD initially enables sorting for plotting and PostScript output only. Setting additional sorting options can result in slower regeneration and redrawing times.

Note: The value of this property is stored in the SORTENTS system variable.

Examples

VBA:

Sub Example_ObjectSortByRedraws()
    ' This example reads and modifies the preference value that controls
    ' the sorting of drawing objects by redraw order.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadDatabasePreferences
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the user preferences object
    Set ACADPref = ThisDrawing.preferences
    
    ' Read and display the original value
    originalValue = ACADPref.ObjectSortByRedraws
    MsgBox "The ObjectSortByRedraws preference is set to: " & originalValue

    ' Modify the ObjectSortByRedraws preference by toggling the value
    ACADPref.ObjectSortByRedraws = Not (ACADPref.ObjectSortByRedraws)
    newValue = ACADPref.ObjectSortByRedraws
    MsgBox "The ObjectSortByRedraws preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.ObjectSortByRedraws = originalValue
    MsgBox "The ObjectSortByRedraws preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ObjectSortByRedraws()
    ;; This example reads and modifies the preference value that controls
    ;; the sorting of drawing objects by redraw order.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))  
    (setq preferences (vla-get-Preferences doc))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-ObjectSortByRedraws preferences))
    (alert (strcat "The ObjectSortByRedraws preference is set to: " (if (= originalValue :vlax-true) "True"  "False")))

    ;; Modify the ObjectSortByRedraws preference by toggling the value
    (vla-put-ObjectSortByRedraws preferences (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-ObjectSortByRedraws preferences))
    (alert (strcat "The ObjectSortByRedraws preference has been set to: " (if (= newValue :vlax-true) "True"  "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-ObjectSortByRedraws preferences originalValue)
    (alert (strcat "The ObjectSortByRedraws preference was reset back to: " (if (= originalValue :vlax-true) "True"  "False")))
)