Triggered when an object has been added to the drawing.
Supported platforms: Windows only
VBA:
object.ObjectAdded(Entity)
Type: Document
An object expression that evaluates to a valid container object. In this case, the only valid container is a document.
Type: A Drawing Object; input to the handler
The object that was added to the drawing. It can be any one of the drawing objects.
No events will be fired while a modal dialog is being displayed.
VBA:
Private Sub AcadDocument_ObjectAdded(ByVal Object As Object) ' This example intercepts a drawing ObjectAdded event. ' ' This event is triggered when an object is added to a drawing. ' ' To trigger this example event: Add an object to an open drawing ' Use the "Object" variable to determine the type of object added MsgBox "A " & TypeName(Object) & " was just added to the drawing!" End Sub
Visual LISP:
Not available