XRefEdit Property (ActiveX)

Determines if the current drawing can be edited in place when being referenced by another user.

Supported platforms: Windows only

Signature

VBA:

object.XRefEdit
object

Type: DatabasePreferences

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value of this property is True.

Note: The value of this property is stored in the XEDIT system variable.

Examples

VBA:

Sub Example_XRefEdit()
    ' This example reads and modifies the preference value that controls
    ' whether the current drawing can be edited in place when being
    ' referenced by another user.
    '
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadDatabasePreferences
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the user preferences object
    Set ACADPref = ThisDrawing.preferences
    
    ' Read and display the original value
    originalValue = ACADPref.XRefEdit
    MsgBox "The XRefEdit preference is set to: " & originalValue

    ' Modify the XRefEdit preference by toggling the value
    ACADPref.XRefEdit = Not (ACADPref.XRefEdit)
    newValue = ACADPref.XRefEdit
    MsgBox "The XRefEdit preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.XRefEdit = originalValue
    MsgBox "The XRefEdit preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_XRefEdit()
    ;; This example reads and modifies the preference value that controls
    ;; whether the current drawing can be edited in place when being
    ;; referenced by another user.
    ;;
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    (setq preferences (vla-get-Preferences doc))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-XRefEdit preferences))
    (alert (strcat "The XRefEdit preference is set to: " (if (= originalValue :vlax-true) "True" "False")))

    ;; Modify the XRefEdit preference by toggling the value
    (vla-put-XRefEdit preferences (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (alert (strcat "The XRefEdit preference has been set to: " (if (= (vla-get-XRefEdit preferences) :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-XRefEdit preferences originalValue)
    (alert (strcat "The XRefEdit preference was reset back to: " (if (= originalValue :vlax-true) "True" "False")))
)