Specifies the directories where AutoCAD searches for support files.
Supported platforms: Windows only
VBA:
object.SupportPath
Type: PreferencesFiles
The object this property applies to.
Read-only: No
Type: String
The directories in which support files are located. Specify a drive letter and path for support, fonts, help, and bonus files.
Use a semicolon (;) to separate multiple directories; however, do not end the string with a semicolon.
VBA:
Sub Example_SupportPath() ' This example returns the current setting of ' SupportPath. It then changes the value, and finally ' it resets the value back to the original setting. Dim preferences As AcadPreferences Dim currSupportPath As String Dim newSupportPath As String Set preferences = ThisDrawing.Application.preferences ' Retrieve the current SupportPath value currSupportPath = preferences.Files.SupportPath MsgBox "The current value for SupportPath is " & currSupportPath, vbInformation, "SupportPath Example" ' Change the value for SupportPath newSupportPath = "TestSupportPath" preferences.Files.SupportPath = newSupportPath MsgBox "The new value for SupportPath is " & newSupportPath, vbInformation, "SupportPath Example" ' Reset SupportPath to its original value preferences.Files.SupportPath = currSupportPath MsgBox "The SupportPath value is reset to " & currSupportPath, vbInformation, "SupportPath Example" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_SupportPath() ;; This example returns the current setting of ;; SupportPath. It then changes the value, and finally ;; it resets the value back to the original setting. (setq acadObj (vlax-get-acad-object)) (setq preferences (vla-get-Preferences acadObj)) ;; Retrieve the current SupportPath value (setq currSupportPath (vla-get-SupportPath (vla-get-Files preferences))) (alert (strcat "The current value for SupportPath is " currSupportPath)) ;; Change the value for SupportPath (setq newSupportPath "TestSupportPath") (vla-put-SupportPath (vla-get-Files preferences) newSupportPath) (alert (strcat "The new value for SupportPath is " newSupportPath)) ;; Reset SupportPath to its original value (vla-put-SupportPath (vla-get-Files preferences) currSupportPath) (alert (strcat "The SupportPath value is reset to " currSupportPath)) )