Hyperlink Object (ActiveX)

A URL and URL description.

Supported Platforms: Windows only

Class Information

Class Name

AcadHyperlink

Object Inheritance
Object
   AcadHyperlink
Create Using

VBA

Hyperlinks.Add
Access Via

VBA

Hyperlinks.Item

Members

These members are part of this object:

Methods

Properties

Events

Delete

Application

URL

URLDescription

URLNamedLocation

None

Remarks

URL and URL descriptions are stored within the XData of their corresponding object. The Hyperlink objects themselves are not stored with the drawing. This means that every time you request the Hyperlink object for an object, a new Hyperlink object is created and the URL and URL description for that hyperlink is read out of the XData. Because of this, you should be careful to avoid creating multiple Hyperlink objects to reference the same URL information. Updating one of these Hyperlink objects would not update the second object.

To create a hyperlink use the Add method.