AddSection Method (ActiveX)

Creates a section plane.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.AddSection(FromPoint, ToPoint, planeVector)
object

Type: Block, ModelSpace, PaperSpace

The objects this method applies to.

FromPoint

Access: Input-only

Type: Variant

The 3D WCS coordinates specifying the finite start point of the section.

ToPoint

Access: Input-only

Type: Variant

The 3D WCS coordinates specifying a point through which the section will pass. The section extends from FromPoint, through ToPoint to infinity.

planeVector

Access: Input-only

Type: Variant

A 3D directional vector specifying the direction of the section plane.

Return Value (RetVal)

Type: Section

The newly created Section object.

Remarks

No additional remarks.

Examples

VBA:

Not available

Visual LISP:

Not available