PaperSpace Property (ActiveX)

Gets the PaperSpace collection for the document.

Supported platforms: Windows only

Signature

VBA:

object.PaperSpace
object

Type: Database, Document

The objects this property applies to.

Property Value

Read-only: Yes

Type: PaperSpace

The PaperSpace collection for the document.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_PaperSpace()
    ' This example sets the variable pspace to the paper space object collection.
    
    Dim pspace As AcadPaperSpace
    Set pspace = ThisDrawing.PaperSpace
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PaperSpace()
    ;; This example sets the variable pspace to the paper space object collection.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq pspace (vla-get-PaperSpace doc))
)