TextFontStyle Property (ActiveX)

Specifies the font style for new text.

Supported platforms: Windows only

Signature

VBA:

object.TextFontStyle
object

Type: PreferencesDisplay

The object this property applies to.

Property Value

Read-only: No

Type: acTextFontStyle enum

Remarks

The initial value for this property is acFontRegular.

Examples

VBA:

Sub Example_TextFontStyle()
    ' This example returns the current setting of
    ' TextFontStyle. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currTextFontStyle As Integer
    Dim constant As String
    Dim newConstant As String
    
    Set preferences = ThisDrawing.Application.Preferences
    
    ' Retrieve the current TextFontStyle value
    currTextFontStyle = preferences.Display.TextFontStyle
    constant = Choose(currTextFontStyle + 1, "acFontRegular", "acFontItalic", "acFontBold", "acFontBoldItalic")
    MsgBox "The current value for TextFontStyle is " & constant, vbInformation, "TextFontStyle Example"
    
    ' Change the value for TextFontStyle
    newConstant = "acFontBoldItalic"
    preferences.Display.TextFontStyle = acFontBoldItalic
    MsgBox "The new value for TextFontStyle is " & newConstant, vbInformation, "TextFontStyle Example"
    
    ' Reset TextFontStyle to its original value
    preferences.Display.TextFontStyle = currTextFontStyle
    MsgBox "The TextFontStyle value is reset to " & constant, vbInformation, "TextFontStyle Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TextFontStyle()
    ;; This example returns the current setting of
    ;; TextFontStyle. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current TextFontStyle value
    (setq currTextFontStyle (vla-get-TextFontStyle (vla-get-Display preferences)))
    (setq constant (cond
                       ((= currTextFontStyle acFontRegular) "acFontRegular")
                       ((= currTextFontStyle acFontItalic) "acFontItalic")
                       ((= currTextFontStyle acFontBold) "acFontBold")
                       ((= currTextFontStyle acFontBoldItalic) "acFontBoldItalic")
                   ))
  
    (alert (strcat "The current value for TextFontStyle is " constant))
    
    ;; Change the value for TextFontStyle
    (vla-put-TextFontStyle (vla-get-Display preferences) acFontBoldItalic)
    (setq newTextFontStyle (vla-get-TextFontStyle (vla-get-Display preferences)))
    (setq newConstant (cond
                       ((= newTextFontStyle acFontRegular) "acFontRegular")
                       ((= newTextFontStyle acFontItalic) "acFontItalic")
                       ((= newTextFontStyle acFontBold) "acFontBold")
                       ((= newTextFontStyle acFontBoldItalic) "acFontBoldItalic")
                   ))
    (alert (strcat "The new value for TextFontStyle is " newConstant))
    
    ;; Reset TextFontStyle to its original value
    (vla-put-TextFontStyle (vla-get-Display preferences) currTextFontStyle)
    (alert (strcat "The TextFontStyle value is reset to " constant))
)