Gets an AcadState object to monitor the state of AutoCAD from out-of-process applications.
Supported platforms: Windows only
VBA:
RetVal = object.GetAcadState()
Type: Application
The object this method applies to.
Type: AcadState
An object containing an IsQuiescent property used to monitor the state of AutoCAD.
It is recommended that you call this method immediately after acquiring the AutoCAD application object. This is the best opportunity to identify AutoCAD in a quiescent state.
VBA:
Sub Example_GetAcadState() ' This example gets the acadState object and checks to see if ' AutoCAD is in a quiescent state. Dim State As AcadState Set State = GetAcadState If State.IsQuiescent Then MsgBox "AutoCAD is quiescent." Else MsgBox "AutoCAD is not quiescent." End If End Sub
Visual LISP:
(vl-load-com) (defun c:Example_GetAcadState() ;; This example gets the acadState object and checks to see if ;; AutoCAD is in a quiescent state. (setq acadObj (vlax-get-acad-object)) (setq State (vla-GetAcadState acadObj)) (if (= (vla-get-IsQuiescent State) :vlax-true) (alert "AutoCAD is quiescent.") (alert "AutoCAD is not quiescent.") ) )