LayerOn Property (ActiveX)

Specifies the state of a layer.

Supported platforms: Windows only

Signature

VBA:

object.LayerOn
object

Type: Layer

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

Objects associated with a turned-off layer are not displayed on the screen or plotted. Unlike the Freeze property, layers that are turned off are generated during a regeneration but are not displayed.

AutoCAD surfaces and circles on a turned-off or frozen layer are invisible but they still hide objects when you use the HIDE, SHADEMODE, or RENDER commands.

Examples

VBA:

Sub Example_LayerOn()
    ' This example creates a new layer called "LayerOn".
    ' It then displays the status of the LayerOn property
    ' for the new layer, toggles the status of the
    ' LayerOn property, and again displays its status.
    ' After running this example, you can check the layer
    ' control on the Object Properties tool bar. It will
    ' show the new layer and the latest LayerOn status.
    
    Dim layerObj As AcadLayer
    
    ' Create the new layer
    Set layerObj = ThisDrawing.Layers.Add("LayerOn")
    
    ' Display the LayerOn status of the new layer
    GoSub DISPLAYSTATUS
    
    ' Toggle the status of the LayerOn property for the layer
    layerObj.LayerOn = Not (layerObj.LayerOn)
    
    ' Display the LayerOn status of the new layer
    GoSub DISPLAYSTATUS
    Exit Sub
    
DISPLAYSTATUS:
    If layerObj.LayerOn Then
        MsgBox "Layer " & layerObj.name & " is turned on.", , "LayerOn Example"
    Else
        MsgBox "Layer " & layerObj.name & " is turned off.", , "LayerOn Example"
    End If
    Return
        
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_LayerOn()
    ;; This example creates a new layer called "LayerOn".
    ;; It then displays the status of the LayerOn property
    ;; for the new layer, toggles the status of the
    ;; LayerOn property, and again displays its status.
    ;; After running this example, you can check the layer
    ;; control on the Object Properties tool bar. It will
    ;; show the new layer and the latest LayerOn status.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Create the new layer
    (setq layerObj (vla-Add (vla-get-Layers doc) "LayerOn"))
    
    ;; Display the LayerOn status of the new layer
    (if (= (vla-get-LayerOn layerObj) :vlax-true)
        (alert (strcat "Layer " (vla-get-Name layerObj) " is turned on."))
        (alert (strcat "Layer " (vla-get-Name layerObj) " is turned off."))
    )

    ;; Toggle the status of the LayerOn property for the layer
    (vla-put-LayerOn layerObj (if (= (vla-get-LayerOn layerObj) :vlax-true) :vlax-false :vlax-true))
    
    ;; Display the LayerOn status of the new layer
    (if (= (vla-get-LayerOn layerObj) :vlax-true)
        (alert (strcat "Layer " (vla-get-Name layerObj) " is turned on."))
        (alert (strcat "Layer " (vla-get-Name layerObj) " is turned off."))
    )
)