HitTest Method (ActiveX)

Performs a hit test on the section plane or table cell at the specified location.

Supported platforms: Windows only

Signature - Section

VBA:

object.HitTest varPtHit, pHit, pSegmentIndex, pPtOnSegment, pSubItem
Object
object

Type: Section

The object this method applies to.

varPtHit

Access: Input-only

Type: Variant

Point at which to perform the hit test.

pHit

Access: Output-only

Type: Boolean

True if the given point lies on the section plane.

pSegmentIndex

Access: Output-only

Type: Integer

Index of segment on the section line that passes near or through the hit point.

pPtOnSegment

Access: Output-only

Type: Variant

The actual point on the section plane geometry. This parameter may return nothing if this data is not required.

pSubItem

Access: Output-only

Type: AcSectionSubItem enum

One or more of the values. This parameter may return nothing if this data is not required.

  • acSectionSubItemBackLine
  • acSectionSubItemBackLineBottom
  • acSectionSubItemBackLineTop
  • acSectionSubItemkNone
  • acSectionSubItemSectionLine
  • acSectionSubItemSectionLineBottom
  • acSectionSubItemSectionLineTop
  • acSectionSubItemVerticalLineBottom
  • acSectionSubItemVerticalLineTop

Signature - Table

VBA:

RetVal = object.HitTest(wpt, wviewVec, resultRowIndex, resultColumnIndex)
object

Type: Table

The object this method applies to.

wpt

Access: Input-only

Type: Variant

3D point in WCS specifying the input pick point.

wviewVec

Access: Input-only

Type: Variant

3D vector in WCS specifying the view direction for the hit test.

resultRowIndex

Access: Output-only

Type: Long

Row index of the selected cell.

resultColumnIndex

Access: Output-only

Type: Long

Column index of the selected cell.

Return Value (RetVal) - Section

No return value.

Return Value (RetVal) - Table

Type: Boolean

True if the hit test is in a table cell.

Remarks

Table: This function performs a hit test by specifying a point and viewing direction. The cell hit by the ray is returned.

Examples

VBA:

Not available

Visual LISP:

Not available