ContourLinesPerSurface Property (ActiveX)

Specifies the number of contour lines (isolines) per surface on objects.

Supported platforms: Windows only

Signature

VBA:

object.ContourLinesPerSurface
object

Type: DatabasePreferences

The object this property applies to.

Property Value

Read-only: No

Type: Integer

The valid range is 0 to 2047.

Remarks

The initial value for this property is 4.



A torus with ContourLinesPerSurface set to 4



A torus with ContourLinesPerSurface set to 20

Note: The value of this property is stored in the ISOLINES system variable.

Examples

VBA:

Sub Example_ContourLinesPerSurface()
    ' This example returns the current setting of
    ' ContourLinesPerSurface. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim currContourLinesPerSurface As Integer
    Dim newContourLinesPerSurface As Integer
        
    ' Retrieve the current ContourLinesPerSurface value
    currContourLinesPerSurface = ThisDrawing.preferences.ContourLinesPerSurface
    MsgBox "The current value for ContourLinesPerSurface is " & currContourLinesPerSurface, vbInformation, "ContourLinesPerSurface Example"
    
    ' Change the value for ContourLinesPerSurface
    newContourLinesPerSurface = 2001
    ThisDrawing.preferences.ContourLinesPerSurface = newContourLinesPerSurface
    MsgBox "The new value for ContourLinesPerSurface is " & newContourLinesPerSurface, vbInformation, "ContourLinesPerSurface Example"
    
    ' Reset ContourLinesPerSurface to its original value
    ThisDrawing.preferences.ContourLinesPerSurface = currContourLinesPerSurface
    MsgBox "The ContourLinesPerSurface value is reset to " & currContourLinesPerSurface, vbInformation, "ContourLinesPerSurface Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ContourLinesPerSurface()
    ;; This example returns the current setting of
    ;; ContourLinesPerSurface. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    (setq preferences (vla-get-Preferences doc))
  
    ;; Retrieve the current ContourLinesPerSurface value
    (setq currContourLinesPerSurface (vla-get-ContourLinesPerSurface preferences))
    (alert (strcat "The current value for ContourLinesPerSurface is " (itoa currContourLinesPerSurface)))
    
    ;; Change the value for ContourLinesPerSurface
    (setq newContourLinesPerSurface 2001)
    (vla-put-ContourLinesPerSurface preferences newContourLinesPerSurface)
    (alert (strcat "The new value for ContourLinesPerSurface is " (itoa newContourLinesPerSurface)))
    
    ;; Reset ContourLinesPerSurface to its original value
    (vla-put-ContourLinesPerSurface preferences currContourLinesPerSurface)
    (alert (strcat "The ContourLinesPerSurface value is reset to " (itoa currContourLinesPerSurface)))
)