EndShortcutMenu Event (ActiveX)

Triggered after the shortcut menu appears.

Supported platforms: Windows only

Signature

VBA:

object.EndShortcutMenu(ShortcutMenu)
object

Type: Document

An object expression that evaluates to a valid container object. In this case, the only valid container is a document.

ShortcutMenu

Type: PopupMenu object; input/output from the handler

The shortcut menu that has been displayed.

Remarks

Use this event to perform any cleanup work on the shortcut menu.

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Private Sub AcadDocument_EndShortcutMenu(ShortcutMenu As AutoCAD.IAcadPopupMenu)
    ' This example intercepts a drawing EndShortcutMenu event.
    '
    ' This event is triggered when the user closes a drawing shortcut menu.
    '
    ' To trigger this example event: Right click the mouse in the working area of a drawing,
    ' wait for the shortcut menu to be displayed and then dismiss the shortcut menu

    MsgBox "A shortcut menu was just closed!"
End Sub

Visual LISP:

Not available