FontFileMap Property (ActiveX)

Specifies the location of the file that defines how AutoCAD should convert unfound fonts.

Supported platforms: Windows only

Signature

VBA:

object.FontFileMap
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The drive, path, and file name of the font mapping file.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_FontFileMap()
    ' This example returns the current setting of
    ' FontFileMap. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currFontFileMap As String
    Dim newFontFileMap As String
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current FontFileMap value
    currFontFileMap = preferences.Files.FontFileMap
    MsgBox "The current value for FontFileMap is " & currFontFileMap, vbInformation, "FontFileMap Example"
    
    ' Change the value for FontFileMap
    newFontFileMap = "TestFontFileMap.fmp"
    preferences.Files.FontFileMap = newFontFileMap
    MsgBox "The new value for FontFileMap is " & newFontFileMap, vbInformation, "FontFileMap Example"
    
    ' Reset FontFileMap to its original value
    preferences.Files.FontFileMap = currFontFileMap
    MsgBox "The FontFileMap value is reset to " & currFontFileMap, vbInformation, "FontFileMap Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_FontFileMap()
    ;; This example returns the current setting of
    ;; FontFileMap. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
  
    ;; Retrieve the current FontFileMap value
    (setq currFontFileMap (vla-get-FontFileMap (vla-get-Files preferences)))
    (alert (strcat "The current value for FontFileMap is " currFontFileMap))
    
    ;; Change the value for FontFileMap
    ;; The file being specified must exist or an error will be generated
    (setq newFontFileMap "C:\\AutoCAD\\TestFontFileMap.fmp")
    (vla-put-FontFileMap (vla-get-Files preferences) newFontFileMap)
    (alert (strcat "The new value for FontFileMap is " newFontFileMap))
    
    ;; Reset FontFileMap to its original value
    (vla-put-FontFileMap (vla-get-Files preferences) currFontFileMap)
    (alert (strcat "The FontFileMap value is reset to " currFontFileMap))
)