PlotLogFilePath Property (ActiveX)

Specifies the path of the Plot log file.

Supported platforms: Windows only

Signature

VBA:

object.PlotLogFilePath
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The path of the Plot log file.

Remarks

This property is equivalent to the AutoCAD Options dialog box setting "Plot and Publish Log File Location."

Examples

VBA:

Sub Example_PlotLogFilePath()
    ' Note: Change the path to a valid folder on your system.
    
    Dim MyPreference As AcadPreferencesFiles
    Set MyPreference = AcadApplication.Preferences.Files
    MyPreference.PlotLogFilePath = "C:\Plots"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PlotLogFilePath()
    ;; Note: Change the path to a valid folder on your system.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))

    (setq MyPreference (vla-get-Files preferences))
    (vla-put-PlotLogFilePath MyPreference "C:\\Plots")
)