AutoSavePath Property (ActiveX)

Specifies the path for the file that is created if you enable automatic save using the AutoSaveInterval property.

Supported platforms: Windows only

Signature

VBA:

object.AutoSavePath
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The drive and path of the automatic save files.

Remarks

Note: The value for this property is stored in the SAVEFILEPATH system variable.

Examples

VBA:

Sub Example_AutoSavePath()
    ' This example returns the current setting of
    ' AutoSavePath. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currAutoSavePath As String
    Dim newAutoSavePath As String
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current AutoSavePath value
    currAutoSavePath = preferences.Files.AutoSavePath
    If currAutoSavePath = "" Then
        MsgBox "AutoSavePath is not currently set.", vbInformation, "AutoSavePath Example"
    Else
        MsgBox "The current value for AutoSavePath is " & currAutoSavePath, vbInformation, "AutoSavePath Example"
    End If
    
    ' Change the value for AutoSavePath
    newAutoSavePath = "C:\AutoCAD\"
    preferences.Files.AutoSavePath = newAutoSavePath
    MsgBox "The new value for AutoSavePath is " & newAutoSavePath, vbInformation, "AutoSavePath Example"
    
    ' Reset AutoSavePath to its original value
    preferences.Files.AutoSavePath = currAutoSavePath
    If currAutoSavePath = "" Then
        MsgBox "AutoSavePath is reset to Null.", vbInformation, "AutoSavePath Example"
    Else
        MsgBox "The AutoSavePath value is reset to " & currAutoSavePath, vbInformation, "AutoSavePath Example"
    End If
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AutoSavePath()
    ;; This example returns the current setting of
    ;; AutoSavePath. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
      
    ;; Retrieve the current AutoSavePath value
    (setq currAutoSavePath (vla-get-AutoSavePath (vla-get-Files preferences)))
  
    (if (= currAutoSavePath "")
        (alert "AutoSavePath is not currently set.")
        (alert "The current value for AutoSavePath is " currAutoSavePath)
    )
    
    ;; Change the value for AutoSavePath
    (setq newAutoSavePath "C:\\AutoCAD\\")
    (vla-put-AutoSavePath (vla-get-Files preferences) newAutoSavePath)
    (alert (strcat "The new value for AutoSavePath is " newAutoSavePath))
    
    ;; Reset AutoSavePath to its original value
    (vla-put-AutoSavePath (vla-get-Files preferences) currAutoSavePath)
    (if (= currAutoSavePath "")
        (alert "AutoSavePath is reset to Null.")
        (alert (strcat "The AutoSavePath value is reset to " currAutoSavePath))
    )
)