AddWedge Method (ActiveX)

Creates a wedge with edges parallel to the axes given the length, width, and height.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.AddWedge(Center, Length, Width, Height)
object

Type: Block, ModelSpace, PaperSpace

The objects this method applies to.

Center

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the center of the wedge face.

Length

Access: Input-only

Type: Double

The length of the wedge corresponding to the X axis. Must be a positive number.

Width

Access: Input-only

Type: Double

The width of the wedge corresponding to the Y axis. Must be a positive number.

Height

Access: Input-only

Type: Double

The height of the wedge corresponding to the Z axis. Must be a positive number.

Return Value (RetVal)

Type: 3DSolid

A 3DSolid object as the newly created wedge.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_AddWedge()
    ' This example creates a wedge in model space.
    
    Dim wedgeObj As Acad3DSolid
    Dim center(0 To 2) As Double
    Dim length As Double
    Dim width As Double
    Dim height As Double
    
    ' Define the wedge
    center(0) = 5#: center(1) = 5#: center(2) = 0
    length = 10#: width = 15#: height = 20#
    
    ' Create the wedge in model space
    Set wedgeObj = ThisDrawing.ModelSpace.AddWedge(center, length, width, height)
    
    ' Change the viewing direction of the viewport
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ZoomAll

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AddWedge()
    ;; This example creates a wedge in model space.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the wedge
    (setq wedgeCenter (vlax-3d-point 5 5 0)
          wedgeLength 10
          wedgeWidth 15
          wedgeHeight 20)
    
    ;; Create the wedge in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq wedgeObj (vla-AddWedge modelSpace wedgeCenter wedgeLength wedgeWidth wedgeHeight))
    
    ;; Change the viewing direction of the viewport
    (setq NewDirection (vlax-3d-point -1 -1 1))
    (setq activeViewport (vla-get-ActiveViewport doc))
    (vla-put-Direction activeViewport NewDirection)
    (vla-put-ActiveViewport doc activeViewport)
    (vla-ZoomAll acadObj)
)