LeaderLength Property (ActiveX)

Specifies the length of the leader on the diameter or radius dimension.

Supported platforms: Windows only

Signature

VBA:

object.LeaderLength
object

Type: DimDiametric, DimRadial

The objects this property applies to.

Property Value

Read-only: No

Type: Double

The length of the leader.

Remarks

The LeaderLength is the distance from the ChordPoint dimension definition point out to where the dimension will do a horizontal dogleg to the annotation text (or stop if no dogleg is necessary). (See the AddDimDiametric or AddDimRadial method for more information.)

Note: The LeaderLength setting will be used only during the creation of the dimension. After the dimension has been saved, changing the LeaderLength value will not affect how the dimension displays. The LeaderLength property is used to calculate the leader location. The value is not saved, and therefore will always return a zero if read.

Examples

VBA:

Sub Example_LeaderLength()
    ' This example creates a diametric dimension
    ' and returns the LeaderLength for that dimension.
    
    Dim dimObj As AcadDimDiametric
    Dim chordPoint(0 To 2) As Double
    Dim farChordPoint(0 To 2) As Double
    Dim leaderLength As Double
    
    ' Define the dimension
    chordPoint(0) = 5#: chordPoint(1) = 3#: chordPoint(2) = 0#
    farChordPoint(0) = 5#: farChordPoint(1) = 5#: farChordPoint(2) = 0#
    leaderLength = 1#
    
    ' Create the diametric dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimDiametric(chordPoint, farChordPoint, leaderLength)
    ZoomAll
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_LeaderLength()
    ;; This example creates a diametric dimension
    ;; and returns the LeaderLength for that dimension.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq chordPoint (vlax-3d-point 5 3 0)
          farChordPoint (vlax-3d-point 5 5 0)
          leaderLength 1)
    
    ;; Create the diametric dimension in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimDiametric modelSpace chordPoint farChordPoint leaderLength))
    (vla-ZoomAll acadObj)
)