GripColorUnselected Property (ActiveX)

Specifies the color of unselected grips.

Supported platforms: Windows only

Signature

VBA:

object.GripColorUnselected
object

Type: PreferencesSelection

The object this property applies to.

Property Value

Read-only: No

Type: acColor enum

Control of the selected grips (drawn as box outlines). The valid range is 1 to 255, or one of the constants listed here:

Remarks

The initial value of this property is 150.

Note: The value for this property is stored in the GRIPCOLOR system variable.

Examples

VBA:

Sub Example_GripColorUnselected()
    ' This example reads and modifies the preference value that controls
    ' the color of unselected grips.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesSelection
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the selection preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Selection
    
    ' Read and display the original value
    originalValue = ACADPref.GripColorUnselected
    MsgBox "The GripColorUnselected preference is set to: " & originalValue

    ' Modify the GripColorUnselected preference by setting it to green
    ACADPref.GripColorUnselected = acGreen
    newValue = ACADPref.GripColorUnselected
    MsgBox "The GripColorUnselected preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.GripColorUnselected = originalValue
    MsgBox "The GripColorUnselected preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_GripColorUnselected()
    ;; This example reads and modifies the preference value that controls
    ;; the color of unselected grips.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))    
    
    ;; Get the selection preferences object
    (setq ACADPref (vla-get-Selection (vla-get-preferences acadObj)))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-GripColorUnselected ACADPref))
    (alert (strcat "The GripColorUnselected preference is set to: " (itoa originalValue)))

    ;; Modify the GripColorUnselected preference by setting it to green
    (vla-put-GripColorUnselected ACADPref acGreen)
    (setq newValue (vla-get-GripColorUnselected ACADPref))
    (alert (strcat "The GripColorUnselected preference has been set to: " (itoa newValue)))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-GripColorUnselected ACADPref originalValue)
    (alert (strcat "The GripColorUnselected preference was reset back to: " (itoa originalValue)))
)